Knowledge Base /
Technical Notes
DeltaV Serial Driver Installation Problem - Error 48
By Tom Freiberger
Product: DeltaV Serial Drivers

This technical note provides a fix for error 48 when installing DeltaV Serial Card drivers.

Problem

The DeltaV Controller and I/O Upgrade Utility included with DeltaV 9.3 or earlier cannot install a driver with a version number greater than 1.55, due to a change in the flash files. While the 1.55 and above drivers are required for Serial Card (PSIC) hardware version 5.6 and later, this problem will affect any Series 2 PSIC when installing a v1.55, or greater, driver. Once the driver is installed on the Serial Card, it is compatible with any DeltaV system that supports a Series 2 PSIC.

The DeltaV Controller and I/O Upgrade Utility will display the error indicated in Figure 1 below.

Figure 1 - DeltaV Controller and I/O Upgrade Utility - Error 48

Affected Systems

  • DeltaV 9.3 or earlier
  • DeltaV Serial Card driver version 1.55 or greater
  • Series 2 Serial Card hardware

Solution

There are two solutions to this problem: 1) Upgrade the card using a DeltaV 10.3 system, or 2) Download the standalone DeltaV Controller and I/O Upgrade Utility below.

Standalone DeltaV Controller and I/O Upgrade Utility

This version of the Upgrade Utility does not need to be installed; it simply needs to be copied to a DeltaV system and run. The serial card driver installation procedure is identical using this utility when compared to the previous versions. Please see the serial card driver's user manual for the installation procedure.

Download the Standalone DeltaV Controller and I/O Upgrade Utility